INICIO FORO
Regresar   ForoCoches > Zona General > Electrónica / Informática

  Ayuda fórmulas Excel  
Respuesta

 
Herramientas
Viejo 13-feb-2020, 15:28   #1
juanillo98
ForoCoches: Miembro
 
Nov 2017 | 2.606 Mens.

Progen T20

Ayuda fórmulas Excel

Buenas shures.

Antes de nada, si veis un disparate intentad disculpadme. No tengo ni idea de programación pero quiero empezar en ello.

El caso es que quiero que en una celda escriba por ejemplo, "agua", si la fecha de hoy es antes del 29 de febrero de 2020 y que ponga tierra si la fecha es después.
De momento, la fórmula que tengo es esta, pero me la da errónea.

Pd, aviso que es excell online y está en español.

=SI(HOY()<FECHA(2020;02;29);[=AGUA];[=TIERRA])

Resultado: fórmula con recuadro en rojo. Vamos, que está mal pero no localizo el error. Seguro que es la mayor gilipollez, pero como no sé aún del tema intento hacer mis pinitos por mi lógica.
juanillo98 está desconectado   Responder Con Cita


Viejo 13-feb-2020, 15:36   #2
Tricepsratops
ForoMúsculos: Triceps
 
Avatar de Tricepsratops
 
May 2014 | 7.394 Mens.
=SI(HOY()<FECHA(2020;02;29);"AGUA";"TIERRA")

Prueba ahora


PD: HOY() es una funcion volatil, es decir, se actualiza cada vez que cambias una celda, por lo que, lo que hoy es 13/02 mañana sera 14/02.
Usa =FECHA

Puzzle 13200 piezas, finalizado Progreso: 100%
Los FunkoPop son el Comic Sans de los coleccionables

Última edición por Tricepsratops fecha: 13-feb-2020 a las 15:39.
Tricepsratops está desconectado   Responder Con Cita
Viejo 13-feb-2020, 15:44   #3
ghiki
ForoCoches: Miembro
 
Avatar de ghiki
 
Mar 2007 | 5.845 Mens.
Lugar: Bilbao
Claro, estás utilizando mal la fórmula, no es fecha, sino hoy
=SI(HOY()<29/02/2020;"CondicionOK";"CondicionNoOK")

Y por cierto, leete la docu oficial
https://support.office.com/es-es/art...c-aa8bbff73be2

Que con esos corchetes ahí te veo muy verde

Última edición por ghiki fecha: 13-feb-2020 a las 15:47.
ghiki está desconectado   Responder Con Cita
Viejo 13-feb-2020, 16:13   #4
ruberw
ForoCoches: Miembro
 
Avatar de ruberw
 
Ene 2014 | 1.415 Mens.
Lugar: Bilbao

Passat tdi 140cv Exclusive

Las comillas shur

ruberw está desconectado   Responder Con Cita


Viejo 13-feb-2020, 16:43   #5
juanillo98
ForoCoches: Miembro
 
Nov 2017 | 2.606 Mens.

Progen T20

Cita:
Originalmente Escrito por ruberw Ver Mensaje
Las comillas shur
La verdad es que no tengo entendido cuando hay que usarlas y cuando no.. D:
juanillo98 está desconectado   Responder Con Cita
Viejo 13-feb-2020, 16:49   #6
juanillo98
ForoCoches: Miembro
 
Nov 2017 | 2.606 Mens.

Progen T20

Cita:
Originalmente Escrito por Tricepsratops Ver Mensaje
=SI(HOY()<FECHA(2020;02;29);"AGUA";"TIERRA")

Prueba ahora


PD: HOY() es una funcion volatil, es decir, se actualiza cada vez que cambias una celda, por lo que, lo que hoy es 13/02 mañana sera 14/02.
Usa =FECHA
No, o sea, pero necesito que se cambie en el dia actual exacto. es decir, que si es antes de la fecha y si es despues ponga otra. No se si me explico o es a lo que te refieres..
Cita:
Originalmente Escrito por ghiki Ver Mensaje
Claro, estás utilizando mal la fórmula, no es fecha, sino hoy
=SI(HOY()<29/02/2020;"CondicionOK";"CondicionNoOK")

Y por cierto, leete la docu oficial
https://support.office.com/es-es/art...c-aa8bbff73be2

Que con esos corchetes ahí te veo muy verde
Es decir, despues del menor que> No hace falta poner fecha?



Los corchetes me los propone Excel directamente a la hora de escribir la formula, en plan plantilla. Ahora adjunto foto. Le echaré un vistazo al enlace, me vendrá bien
juanillo98 está desconectado   Responder Con Cita
Viejo 13-feb-2020, 17:04   #7
namx
ForoCoches: Miembro
 
Avatar de namx
 
Ago 2019 | 213 Mens.
Lugar: de pasado mañana

honda civic coupé

Cita:
Originalmente Escrito por juanillo98 Ver Mensaje
La verdad es que no tengo entendido cuando hay que usarlas y cuando no.. D:
Las comillas se usan con valores textuales, o en búsquedas con la función contar.si, por ejemplo. Para valores numéricos y fechas no hay que usar comillas
namx está desconectado   Responder Con Cita
Viejo 13-feb-2020, 17:21   #8
ghiki
ForoCoches: Miembro
 
Avatar de ghiki
 
Mar 2007 | 5.845 Mens.
Lugar: Bilbao
Cita:
Originalmente Escrito por juanillo98 Ver Mensaje
No, o sea, pero necesito que se cambie en el dia actual exacto. es decir, que si es antes de la fecha y si es despues ponga otra. No se si me explico o es a lo que te refieres..

Es decir, despues del menor que> No hace falta poner fecha?



Los corchetes me los propone Excel directamente a la hora de escribir la formula, en plan plantilla. Ahora adjunto foto. Le echaré un vistazo al enlace, me vendrá bien
Eso es, internamente, excel cambia la fecha a numero decimal para compararlo con el dia actual y decidir si es mayor o menor; es decir, realmente usa el dia "43890" para compararlo con el dia actual (ese dia en el caso del 29/02/2020, excel utiliza el 01/01/1900 como referencia -según version-).


Lo de las comillas, como dice el shur de arriba, es para que no aplique ninguna formula ni cálculo sobre lo que hay dentro, que lo muestre "tal cual"
ghiki está desconectado   Responder Con Cita
Viejo 14-feb-2020, 13:09   #9
juanillo98
ForoCoches: Miembro
 
Nov 2017 | 2.606 Mens.

Progen T20

Cita:
Originalmente Escrito por ghiki Ver Mensaje
Claro, estás utilizando mal la fórmula, no es fecha, sino hoy
=SI(HOY()<29/02/2020;"CondicionOK";"CondicionNoOK")

Y por cierto, leete la docu oficial
https://support.office.com/es-es/art...c-aa8bbff73be2

Que con esos corchetes ahí te veo muy verde
Hola shur.
Hoy he probado como dices. Poniendo una fecha anterior, el valor no cambia.. D:
juanillo98 está desconectado   Responder Con Cita
Viejo 14-feb-2020, 14:06   #10
Edding3000
ForoCoches: Usuario
 
Avatar de Edding3000
 
Dic 2019 | 173 Mens.
=SI(K2<=K1;"AGUA";"TIERRA")


En K2 pones la formula =HOY()
En K1 pones 29/02/2020


sin usar celdas complementarias:


=SI(HOY()<=FECHA(2020;2;29);"AGUA";"TIERRA")




revisa el formato de la FECHA porque yo lo tengo en ingles, y tal vez a ti el orden de año/mes/dia sea diferente

Última edición por Edding3000 fecha: 14-feb-2020 a las 14:10.
Edding3000 está desconectado   Responder Con Cita
Viejo 14-feb-2020, 14:11   #11
Edding3000
ForoCoches: Usuario
 
Avatar de Edding3000
 
Dic 2019 | 173 Mens.
Cita:
Originalmente Escrito por juanillo98 Ver Mensaje
Hola shur.
Hoy he probado como dices. Poniendo una fecha anterior, el valor no cambia.. D:

al shur le faltaba el <=, solo tiene < y luego la fecha con la formula de fecha


mira mi post arriba
Edding3000 está desconectado   Responder Con Cita
Viejo 14-feb-2020, 17:54   #12
ghiki
ForoCoches: Miembro
 
Avatar de ghiki
 
Mar 2007 | 5.845 Mens.
Lugar: Bilbao
Cita:
Originalmente Escrito por juanillo98 Ver Mensaje
Hola shur.
Hoy he probado como dices. Poniendo una fecha anterior, el valor no cambia.. D:
Hostia, pues acabo de probar y es cierto, solo cambia con números absolutos.

Como dice el shur de arriba he comprobado y si funciona
Cita:
=SI(HOY()<FECHA(2020;02;29);"AGUA";"TIERRA")
por lo que veo , hay que usar FECHA para que pille las fechas como día/mes/año
ghiki está desconectado   Responder Con Cita




Respuesta

Regresar   Inicio | ForoCoches > Zona General > Electrónica / Informática

Regresar Amazon.es

    - Electrónica
    - Informática
    - VideoJuegos
    - Libros
    - Bricolaje y Herramientas
 PCComponentes.com

    - Componentes
    - Periféricos
    - Ordenadores
    - Smartphones
    - Audio/Foto/Video

Regresar  Tiendas Chinas:

    - GearBest
    - BangGood
Herramientas


 [ VERSIÓN MÓVIL ]
Info Legal | Privacidad | Cookies | Notificaciones | Normas de uso | Publicidad | Updates | Stats | Ayuda | Invitaciones | Contacto